Tangent Control Surface Support

Tangent - Code Plugins - Oct 20, 2022

Enables Tangent Panels to control the Unreal Engine Editor. Comes with a wide range of built-in functions and the ability to train more.

  • Supported Platforms
  • Supported Engine Versions
    4.27, 5.0 - 5.1
  • Download Type
    Engine Plugin
    This product contains a code plugin, complete with pre-built binaries and all its source code that integrates with Unreal Engine, which can be installed to an engine version of your choice then enabled on a per-project basis.

Enhance your UE Editor productivity with a Tangent Control Surface. With many properties available at your fingertips on Buttons, Knobs and Trackerballs you can make adjustments more quickly and with greater precision. Built-in capabilities include:

  • Object transforms
  • Camera properties
  • Light properties
  • Post Process Volume Color Grading properties
  • Color Correction Region properties
  • Sequencer functions
  • Actor quick-selection


Take a tour with our Tangent UE Plugin Video


The plugin ships with a predefined control layout for each Tangent panel type. However, you can modify this using our Mapper tool to rearrange functions, add new ones and to alter individual control sensitivities. Keyboard shortcuts and OSC commands can also be included in your custom map.

If you find a function within the UE Editor which is not available from the built-in list of functions then you can quickly train a control on the panel to drive it.


This plugin provides support for all Tangent Control Surfaces including the Element-Vs app (virtual control surface) for iOS and Android. Details of all our products can be found on our website.

Technical Details

In addition to the above features, the plugin supports:

  •  2 additional transform reference frames: Camera & Viewport
  • All color-space functions can be controlled in RGB, HSV and YUV
  • Multi-User
  • Undo/Redo & History


Supported Development Platforms: Windows, macOS

Supported Target Build Platforms: 4.27, 5.0 & 5.1

Documentation: Tangent UE Plugin Quick Start Guide

Video: Tangent UE Plugin Tour

Important/Additional Notes: Requires Tangent Hub & Mapper V1.7.9 or later.